× Support requests and general discussions

does not comply with RFC 2822, 3.6.2. after update to 9.3.1

More
29 Dec 2018 23:05 #1 by Martine Reeh
Hi Fox,

I updated to 9.3.1 and now suddenly my forms return an "error 0" screen with the message that:

Address in mailbox given [{email}] does not comply with RFC 2822, 3.6.2.

I thought it was a database issue, so I restored to an earlier version of the site, with an earlier version of Fox Contact (3.8.2) and all was good and right in the world. But then I updated to 9.3.1 and "boom!" error page.

The funny part is that I (admin) do get the form results in my email, but the user does not get a confirmation.

Please help me to figure out what is going on.

Thanks,
Martine

Joomla 3.9.1
Fox 3.9.3
PhP: 7.1

Please Log in or Create an account to join the conversation.

More
13 Feb 2019 15:53 #2 by Tom
Hi Martine, I found out something, even though it was a while ago.
I had the same mistake and tried everything. It worked in the settings of Fox Contact. The second tab contains the e-mail manager. And that is alternatively put on Fox. What does not work then. The conversion to Joomla has fixed the bug.
Good luck

Please Log in or Create an account to join the conversation.

More
27 Sep 2019 19:59 - 03 Oct 2019 13:24 #3 by AndCom
Hello,

The forms are inactive !!
Error page: does not comply with RFC 2822, 3.6.2.

I can not find the solution on your forum.

Thank you for your reply
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Sep 2019 13:06 - 30 Sep 2019 07:41 #4 by AndCom
I switched to 7.3 global PHP version.

Please Log in or Create an account to join the conversation.

More
28 Sep 2019 20:39 - 03 Oct 2019 13:28 #5 by AndCom
Hello again,

Like Martine, messages that in the administration of the website.

The form works by going to System Administration> Configuration. SERVER Putting in E-mail Settings: E-mail Server> PHP Mail Then in Server Settings> Temporary Folder> www / tmp
Go to the FTP and give him the agreement to write (access file on the right: 755).

See the attached image. Despite this, sending an attachment always tells me EROR

Thanks for your reply
Attachments:

Please Log in or Create an account to join the conversation.

More
03 Oct 2019 13:46 - 18 Oct 2019 18:36 #6 by AndCom
support ??
.............???????????????????


Correction


Hi,

I finally managed to fix this problem !!
Despite the lack of help from the community .... and the developer ???

1) Set the uploads file to 777
(components> com_foxcontact> uploads)

2) SERVER > ACCOMMODATION > Multisite > Disable the Firewall on :
your-domain.com and on www.your-domain.com

I hope this will save you the time I lost myself...
Good continuation

Nonostante ciò, non c'è supporto !!!!!!

Please Log in or Create an account to join the conversation.

More
22 Dec 2019 22:31 - 22 Dec 2019 22:37 #7 by AndCom
Another solution ---> Deactivate the Anti-Spam function in the module to stop the sending error (see image below).
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Jan 2020 13:15 #8 by Juan Carlos
I also had that error, but it was because I used ";" and not a "," when adding emails to send with a copy.

Please Log in or Create an account to join the conversation.

More
16 Jun 2020 21:11 - 16 Jun 2020 21:16 #9 by AndCom
I do not understand your answer ?

A comma or !!
Where ";" and not a "," ??



On four websites the forms work on 2 and on the other 2 there is this famous problem of RFC not compliant ???

I have not been able to correct this problem for 1 year now .....

Please Log in or Create an account to join the conversation.