Joomla compatibility list

More
06 Apr 2011 22:14 - 27 Mar 2017 22:59 #1 by Demis [Fox-Labs]

Content index

1. Version numbering

2. Joomla Compatibility

3. Browsers Compatibility

4. PHP Compatibility

5. Administrator templates compatibility

6. End of support


1. Version numbering

Due to the change in the Joomla release strategy and version numbering , starting with Fox Contact 3.5 we have changed our version numbering accordingly, and we have adopted the "Semantic Versioning".

Our version identifiers now follow a three level numerical convention where the levels are defined by the software change significance.

Major.Minor.Maintenance
Example: 3.6.1 means Major Version = 3, Minor Version = 6 and Maintenance Version = 1.

Increments inindicate
Major Version IdentifierMassive architectural changes that breaks the backward compatibility.
Minor Version IdentifierAddition of new features or a significant change to existing features.
Maintenance Version IdentifierFixes to bugs or usability issues

Tip: Despite we test extensively our software before releasing it, a release with a Maintenance Identifier of 0 (Example: 3.5.0 or 3.6.0) is likely to contain some minor bugs. In that case, expect the first maintenance version for that series (Example: 3.5.1 or 3.6.1), to be released within a few days or weeks.


2. Joomla Compatibility

Before installing or updating Fox Contact, ensure that the version you are about to install is compatible with your version of Joomla.

To avoid confusion, Fox Contact is numbered using the same Major number as the Joomla version on which it is compatible.
Example: Fox Contact 2.x runs on Joomla 2.x only, while Fox Contact 3.x runs on Joomla 3.x only, and so on.

Fox ContactStateworks on Joomla
2.5Security fixes only1.6, 1.7, 2.5
3.2End of life3.0, 3.1, 3.2
3.4Security fixes only3.3, 3.4
3.6Security fixes only3.3, 3.4, 3.5, 3.6
3.7Active support3.5, 3.6, 3.7

Similarly, before updating Joomla, ensure that the compatibility requirements are still satisfied and if necessary, update Fox Contact too.

As a general rule, you should always use the most recent version of Fox Contact written for your version of Joomla.

Fox Contact from 1.6 to 3.3 series as well as Joomla from 1.6 to 3.4 series are obsolete, unsupported and may include security risks.

What's the problem with obsolete software?
  1. It is not guaranteed to work. Known problems have often already been discovered and fixed in newer versions. Why using a release which is clearly defective?
  2. It is not supported. As long as it works no problem, but when something goes wrong, the support team can't provide technical assistance.


4. Browsers Compatibility
Keeping in line with industry best practices and our value for security, we have discontinued support for Internet Explorer 10 an older versions.

4. PHP Compatibility

The Minimum and Recommended PHP requirements to run Fox Contact, are the same as Joomla .
However, the market share of PHP 5.3 is so limited that currently we don't test our code on that platform until a problem is being reported.
To understand this policy, consider that PHP 5.3 goes back to the remote year 2012.
The subsequent versions, don't look much better: PHP 5.4 has reached its end of life in September, 2015, and PHP 5.5 is going to suffer the same fate within July 2016.
See PHP versions .
Of course, Fox Contact is fully compatible with PHP 7 which is the current stable version of PHP. It's obvious, but it's worth mentioning it, since many people ask this question.


5. Administrator templates compatibility

Fox Contact 3.5 and newer, includes a powerful visual designer, that heavily relies on the default Joomla administrator template, which is called Isis.
Another administrator template, which is called Hathor, is available on Joomla 3 and newer, but Fox Contact will not work there. Please use Isis template instead.


6. End of support

Each major release of Fox Contact follows the same life cycle of Joomla, therefore it is supported with regular and free upgrades at least as long as the corresponding Joomla release remains supported by the Joomla developers (but we usually extend our support period even more).

Currently, our support to Fox Contact 2.5 series, which runs on Joomla 2.5, is limited to security fixes only. Further updates will be released on as-needed basis.
The following user(s) said Thank You: sergey

Please Log in or Create an account to join the conversation.